Why is Motorola DROID Turbo's mic not working?

I bought the Droid Turbo a little over 2 weeks ago. Last night I noticed that Moto Voice wasn't responding and saw that it had been disabled and wouldn't let me enable it again. I restarted the phone and reset the Moto app (uninstalled updates and updated them again) which allowed me to go through the setup process but when I got to the section for recording my voice it couldn't pick anything up. I then tried Google Now Voice commands, having someone call me, and a voice recorder - nothing was picking up my voice. Then I did a factory reset and still had the same problem, which left me to assume it was a hardware issue.

I was going to go to the Verizon store today to see if they would replace it, but this morning I tried it again and everything seemed to work including Moto voice. About a half hour later Moto voice was not working and I saw that it was once again disabled and wouldn't let me enable it. This time Google Now and the voice recorder were still working.

I have not dropped the phone or gotten it wet, it still looks and functions like new (besides the mic). I don't want to wait too long to try and exchange it but at this point I don't know if I can even prove that there's a problem. I'm guessing it's a software issue - It just seems strange that the mic seemed to be fully disabled before and after a factory reset then suddenly work the next day.

Any ideas what it could be or how to fix it?




Looks like a defective unit.. Hmm.. I guess your only option if you don't want it repaired again is by using a headset.



Not the answer you were looking for?