rajesh tewari

Why can't I download any app on the Micromax Canvas Fire A104?

when i go to download any app in my mobile it replies as Error while downloading... there is insufficient space on the device. while there is 1.14 GB space in mobile and 2.2 GB space in sd card.




My micromax battery ran out and when I put it on charge, it won't charge or turn on. Is the battery dead or is the phone gone?

My doodle doesn't allow to download whereas the space is fucking enough (more than 2.5 GB) in both memories.....what I want to download is only 20 mb....so my dear fucking micromax , what the fuck is going on in my phoooone?????


Rohan Vastad

HI,
Few months ago i got Micromax canvas. Like every android i have connection to google play store but only one problem is i cant even download any apps. In all i have downloaded like three aps and that's it. Every time i can see ,,error while downloading (name of app) There is insufficient space on the device.'' I don't know what to do. Maybe i have to change place with downloads apps or something. Also i had delete everything from my phone but it haven't worked. Please someone help change device maybe this is main problem .


Ausmeet leeyan
Ausmeet leeyan

I have already 5gb space but when I download from play store there is show you have not space for download this app


thiruvengadam
thiruvengadam

my pro is play store nor working


Girish_84339

I do have the same issue, it should either ask for the location to download to SD card
else we should be able to move the existing apps to SD card from phone memory.
Unfortunately nothing is happening, looks like a bug which Micromax should start investigating. I just checked with Samsung, we can easily move our apps to SD card and get more space for new downloads. ITS SO SIMPLE... MICROMAX make it complicated.....


Varun Sharma
Varun Sharma

I just bought A104 recently and have 8 GB SD card memory. Still after downloading couple of apps 7gb space is left but still during downloading message of insufficient memory space is popping up. I am fed up with this problem. Erasing unnecessary data and restarting again are some of the actions I opt to get a app downloaded but still problem persists.


Hmm.. Have you tried restoring the phone to factory settings? If not yet, I suggest that you try that.



Not the answer you were looking for?