My Alcatel One Touch Scribe HD doesn't boot. What can I do?

My phone's not booting no matter what I do. I left it in my bag fully charged and then when I got it after 30 minutes, it's off and I can't boot it. Note: My phone was fully charged when I put it inside my bag. I didn't even bump my bag or anything. It was just there. When I got my phone, there were no cracks or any sign of bumps. It didn't even get squished. I tried plugging it to a charger but nothing's happening. Tried removing my sd card and try booting it again but nothing's happening. Even tried pressing the volume up key and boot button for a hard reset, nothing. Please help! *Alcatel One Touch Scribe HD




Hi i bought my alcatel scribe two days ago and now i got the same problem :/ i where on class and had the phone on the table suddenly it just went black and when i connected the charger nothing happened :(


This is not the answer man,just letting you know am having same issue,exactly 3 times happened to me plus some more strange things phone does itself like when runs out of battery and turns off, after 10 minutes off it started vibrating itself for 15 minutes.:(
If I conect the audi jack the screen touch doesnt work properly and you press a tab in bottom of window and clicks on top of screen randomly. So good luck.


Hi Rei. I suggest you contact Alcatel or the store you purchase your phone from to find out how you can have your phone checked and repaired.



Not the answer you were looking for?