Why does the Alcatel One Touch 356 show 'Failed' when trying to make a call with a Telus SIM?

I have an unlocked Alcatel 356 used on the Petro-Canada Mobility network. When I put a SIM card from Rogers, all it works well. When I insert a SIM card from (a perfectly working during last 3-4 years) a Telus phone, first a coin-like circle appears with the message "Searching". After it goes away I am able to initiate a call, but the response (after an attempt to call the remote party) invariably comes as "Failed".
None of this happens either with the Petro-Canada SIM card nor with Rogers SIM card.
Note - from what I know, Petro-Canada Mobility uses the underlying GSM network from Rogers.




Thank you very much Grindale P. That is in fact what I did. It turns out that Telus does not support GSM network. My confusion was caused by the fact that when I unlocked my Samsung tablet, the same Telus SIM card worked there. Upon a little more of investigation I found out that my tablet supported ALL networks, including the HSPA that both Telus and Bell use. My simple phone does not support HSPA but only GSM. Mystery solved. Since GSM is the network I will be using in Peru, it looks like everything should be Ok.
Thanks again Grindale P.


I suggest you visit a Telus store and let their reps check your phone for compatibility issues.



Not the answer you were looking for?