My Verizon Wireless Ellipsis 7 won't power on or do anything. Can anyone help?

Last night I plugged the tab in before I went to bed. It was charged to (98%) when I woke. I unplugged it and it said 3% & to plug in the charger. It has been on the charger all day and doesn't show that it's charging or any sign of life.
The thing is 4 days old. I haven't downloaded many apps. The apps I did download were like Facebook and Pandora etc, nothing out of the ordinary. it hasn't been dropped and hasn't froze or given me any other problems before now. But this is making me seriously hate the thing.




Brother gave me an ellipsis , was aware of the charging problem as I’ve used them before.  Now having the problem with this one and it’s dead! don’t hear of this problem with Apple products!


Just tried this with my tablet and it worked.  Thank you!!!


the power and volume down button just worked for me, maybe 15 seconds, first showed that it was charging and now was able to turn on, thank you!!  glad I have my computer still!!


someone plz help!!! i jave an Elipsis 7 and need to do a hard reset but every single option given has not worked. i tried vol + and power, vol - n power, ive tried both and power, i tried power for 20 sec and again for 3.....NOTHING WORKS. 


PLEASE HELP


"I just had this problem today but was able to resolve it quickly. I called tech. support and the service rep. had me reset my Ellipsis 7 by simultaneously holding the power button and the down volume button. It took about 10 seconds before the word "Welcome" appeared and the device began to function as usual without any data loss or problems. The rep. suggested that occasionally restarting or powering off the device (e.g., weekly) should prevent this problem in the future. I was relieved because I had only had the device for two weeks and nothing unusual happened to it!"


AWESOME! I was afraid that all was lost! Thanks Micah


I got this tablet about 2 weeks ago, and was playing bloons tower defense 4 (good game by the way). Then the power went out. No big deal, I thought. But right now, it's at 100%, and it wont turn on! Power and down volume button doesn't work, and neither does hold for 10 seconds, then 3 seconds. Any help?


My ellipse 7 was on the charger all night and when I woke up it said "welcome" but it stayed like that. Then it started putting colorful chinese words and the screen was black. Then after pressing the on button continuously it came on. But there was a bad side to it....IT RESET everything was wiped out. But it came on and worked fine. I only downloaded a little bit of apps and protected browser prior. But its good now and I was happy it still worked.


I got this model on a Verizon promotion.  First I said no, then the salesman said "don't  you have a grandkid that could use it?  So, reluctantly I agreed and brought it home.  Used it a few times, put it away and forgot about it.  Now my grandchild could use it so I took it out, had it charging for 1 day and a night, I got, red screen, then the red screen with checkmark, then black screen with battery with a charge mark on it, then a battery with a question mark.  Tried the above fixes got nothing.  Wow, now I know why they were giving them away.



Ive had the E7 in a box for over a year. Decided to use it. Had to keep rebooting constantly after every ten minutes. Verizon said it needed to have a system update. Charged it and screen has gone completely black. Tried all suggestions, cannot get it to turn on, therefore I cannot even do the system update. Very disappointed in the crap Verizon has given to the public. Now I know why they were free. Thanks everyone for the suggestions.

Thanx to Micah for his answer...It works !!!

Thank you for the help, it worked! I got this for my grandson and was perplexed as to why he couldn't get it to turn on anymore. So happy I found you on the Internet?

I cannot get my verizon 7 to turn on. I have tried all of the solutions offered on this blog. Nothing has helped. Verizon has produced a lousy product and should refund the money that people paid in good faith.


Well so far I got a battery signal that the most I've had in 2 weeks I'm coming to conclusion that these tablet are not worth the money they sold them for but thanks for your help

Mine won't do nothing screen won't come on and won't come on while it's charging my wife was on it playing and she said it just cut off the she had 75% on it idk what to do

Have the same problem tablet charges, turns on, freezes then the screen turns white I tried everything


Had the same problem like everyone , else tried the power on volume down trick . works just fine now.

my verizon ellipsis 7 want turn on . i plug charger in and it show the charger icon then it goes to android logo goes black and repeats that and thats all i get.

Thanks for this info. I was really getting ready upset. Lol


Not the answer you were looking for?