Why can't I receive picture messages on my ZTE ZMAX Pro?

I have the zmax pro the new one and i cant recieve pic messages but i can send them. I go thru metro pcs. Someone help .?




. Go to "main menu", then click on "settings". 

2. Under "wireless & Network settings", click on WIFI. Turn it off (temporarily). Then, hit the back "arrow" symbol on the upper left hand corner.

3. Go to "connect PC". Make sure the option "charge only" (charge your phone via USB is selected). Then, hit the back "arrow" symbol on the upper left hand corner.

4. (You should be back in "settings"). Click on "Cellular Network". Make sure "mobile data" is on. Under this SAME setting, (Cellular Network); locate "Access Point Name". (APN). Click on it. You should see "MetroPCS". Under that heading, it should show "fast.metropcs.com". 

5. On that same screen, on the upper right hand corner, you should see the black 3 lines (the options symbol) Click on​ that. The only option that comes up is "Reset to Default". Click on that. It will reset for you, & you shouldn't loose any of your info, pictures, etc.

6. Try sending mms, pictures to someone. It can take up to 5 mins for the person to receive it after this initial reset.


I hope this will resolve your issues as well. 


  1. Go to Settings > Cellular Network > Access Point Names
  2. Touch the + sign
  3. Check this page and copy the settings: click here
  4. Tap the menu icon (3 dots icon) > Save.

Now if you are receiving a message with attachment and still won't save to your phone, enable mobile data then try saving the attachment. Let us know if that works.


Hi Jeri. Check APN settings if it's updated to what MetroPCS is providing.



Not the answer you were looking for?